Skip to content

测试任务 ​

说明

  1. 测试任务包括特效测试、灯光测试和解算测试,均位于模型环节。
  2. 先添加并发布资产生成任务,再查看对应测试任务的上游任务和上游文件。
  3. 测试制作完成后,提交审核;达到发布条件后执行发布。

一、添加测试资产 ​

1.1、新增资产 ​

入口:资产清单 -> 添加资产

填写资产名、集数和场次等基本信息,按实际制作需求选择资产类型和属性后保存。测试集可选择项目中已配置的 TST 集数。

下图以“灯光测试资产”为例。资产名用于区分测试内容,资产类型仍需按实际对象选择。

添加测试资产

1.2、发布资产生成任务 ​

入口:资产清单 -> 勾选资产 -> 发布

确认资产信息后发布资产,系统根据项目工序流模板和资产属性生成对应的工序任务。生成后,在资产卡片的“制作进度”或任务库中查看测试任务,并分配执行人和计划时间。

测试工序是否生成以项目工序流模板和资产属性为准。配置及操作可参考配置项目和创建任务。

二、特效测试任务 ​

2.1、添加特效测试任务 ​

按第一节添加并发布需要进行特效测试的资产,在生成的模型环节任务中找到“特效测试”。确认资产、执行人和计划时间后,打开该任务卡片。

2.2、查看上游任务 ​

入口:特效测试任务卡片 -> 上游任务

示例中,特效测试任务关联以下上游任务:

上游环节/工序关联类型
模型 / 模型影响交付
模型 / 引擎材质仅关联

可在列表中查看上游任务状态、最新版本、使用版本及执行人。

特效测试上游任务

特效测试上游任务列表

三、灯光测试任务 ​

3.1、添加灯光测试任务 ​

按第一节添加并发布需要进行灯光测试的资产,在生成的模型环节任务中找到“灯光测试”。确认资产、执行人和计划时间后,打开该任务卡片。

3.2、查看上游任务 ​

入口:灯光测试任务卡片 -> 上游任务

示例中,灯光测试任务关联以下上游任务:

上游环节/工序关联类型
模型 / 模型影响交付
模型 / 引擎材质仅关联

灯光测试上游任务

四、解算测试任务 ​

4.1、添加解算测试任务 ​

按第一节添加并发布需要进行解算测试的资产,在生成的模型环节任务中找到“解算测试”。确认资产、执行人和计划时间后,打开该任务卡片。

4.2、查看上游任务 ​

入口:解算测试任务卡片 -> 上游任务

示例中,解算测试任务关联以下上游任务:

上游环节/工序关联类型
模型 / 模型影响交付
模型 / 引擎材质仅关联

解算测试上游任务

五、获取上游文件并开始制作 ​

5.1、查看上游文件 ​

入口:测试任务卡片 -> 任务文件 -> 上游文件

查看模型、引擎材质等上游任务的文件和版本,按需要下载制作文件。上游关系及使用版本以当前任务实际配置为准。

5.2、开始任务 ​

入口:工作管理工具 -> 我的任务 -> 选择测试任务 -> 开始任务

选择对应项目和资产下的测试工序,确认右侧执行项后,点击“开始任务”。以灯光测试为例,工具会检查模型上游是否已发布、打开模型 publish 文件、保存工作文件及任务配置信息,并修改任务状态为“进行中”。

灯光测试开始任务

六、提交审核 ​

入口:测试任务卡片 -> 提交

完成测试制作后,打开对应任务卡片,点击右上角“提交”。下图以灯光测试任务为例。

灯光测试提交入口

  1. 确认当前项目、资产和测试工序。
  2. 确认必需的工作文件已保存,上传本次测试的审核文件。
  3. 按项目审核配置选择审核人并提交,等待审核结果;需要修改时,完成修改后再次提交。

说明

发布审核通过后,任务进入“待发布”状态。未配置审核流时,提交后自动通过并进入“待发布”。提交方式可参考提交任务,审核流配置可参考配置项目。

七、发布测试任务 ​

7.1、任务卡片发布入口 ​

入口:测试任务卡片 -> 发布

任务达到发布条件后,点击右上角“发布”。下图以状态为“待发布”的特效测试任务为例。

特效测试发布入口

7.2、通过工具发布 ​

入口:发布下游工具 -> 选择项目、资产和测试工序 -> 发布

确认当前工序与要发布的测试任务一致,检查版本和质检结果后点击“发布”。下图以灯光测试为例,发布执行项包括拷贝审核文件到 publish、写出 XML、上传发布文件至服务器及更改任务状态。

灯光测试发布下游

发布完成后,返回任务卡片,在“任务版本”和“任务文件 -> 发布文件”中确认发布结果。工具发布操作可参考发布任务。